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1 - INTRODUCTION 
 
The following description of the processing steps that were implemented in generating this paper's results is 
designed to assist in applying the procedures to other projects. QGIS, the software used in this project, is an Open 
Source, Geographic Information System (GIS) program comparable to the industry standard ArcGIS. Some 
proficiency with QGIS is recommended, but a large amount of detail is provided, so a novice can expect to make 
rapid progress. The diverse tools used here and the method of presentation also provide a new user the 
opportunity to learn many QGIS techniques. 
 
Versions 3.10 and 3.20 of QGIS were used in this project; these and other versions can be downloaded from the 
QGIS website at: https://qgis.org/en/site/. The "Long term release (most stable)" is your best choice. Abundant 
documentation (https://docs.qgis.org/3.16/en/docs/index.html) and training resources 
(https://docs.qgis.org/3.16/en/docs/training_manual/index.html) are available online to aid in getting started. 
 
In what follows, directions for implementing processing steps are presented in sequential order with a 
combination of descriptive text, images of dialog boxes used to run processing tools and maps and other images 
(identifiable as Figures with captions) produced by the tools. You can find QGIS dialog boxes by following the 
descriptions enclosed in brackets ([ ]); greater-than symbols (>) separate descending, hierarchical levels of access 
ending in the tool name or other instruction. Additional descriptions for some dialog box elements are added 
where appropriate. Where processing procedures for different methods are redundant, the user will be directed to 
a preceding description.  
 
 The three new methods of computing flood inundation maps described in the paper can be characterized by 
the external data required for input by each. All the methods require a high-resolution digital elevation model 
(DEM) and a polygon defining the boundary of the watershed. Precise coordinates of points along the deepest part 
of the thalweg are important and are derived from the DEM. Additional data requirements are: 

 Method 1: XYZ coordinates of flood level elevations (Zws) measured in the field near the stream. 
 Method 2: Constants a and b in Eq. 2 of the paper. 
 Method 3: Constants b and c in Eq. 3 of the paper. 
 Method 2 is not treated in this Supplement. It is the simplest of the three methods, and its procedures can be 
derived by modifying the procedures of Method 3.  
  
 Although many processing steps are required to accomplish the goals of these procedures, most can be set up 
and executed quickly. The most time-consuming steps are those requiring manual editing of stream data. A 
proficient user can expect to complete a project in a few days, depending on the project's complexity.  
  
  



2 - QGIS GRAPHICAL INTERFACE LAYOUT 
 
Fig. 1 shows the QGIS graphical interface containing a watershed map in the project window. Three panels are 
displayed on the sides - 'Layers' (denoted by Layers when referred to in processing steps below),  'Processing 
Toolbox' (Toolbox) and 'Layer Style' (Style). At a minimum you should install these panels in QGIS. Multiple 
'Toolbars' (Toolbar) are installed near the top. Essential toolbars are the 'Map Navigation Toolbar', 'Attributes 
Toolbar', 'Digitizing Toolbar' and 'Advanced Digitizing Toolbar'. These features plus the QGIS 'main menu' 
(Menu) facilitate rapid and powerful manipulation of geographic data. You can select panels and toolbars to 
install from [Menu > View > Panels] and [Menu > View > Toolbars], or you can simply right-click on any 
toolbar to immediately access a list of panels and toolbars. 
   

 

Figure 1: QGIS GUI display on Mac OSX showing the Deer Creek watershed and DEM in St. Louis county, MO and the derived thalweg in 
the project window. Also shown are recommended panels and toolbars. 



3 - PREPROCESSING 
 
 Preprocessing entails 2 main steps: 1) acquiring and preparing the DEM and 2) extracting precise coordinates 
of the stream's thalweg. Once these preliminary steps are successfully completed for a project, deriving variations 
on the inundation maps is straightforward. Note that each project's data layers must all be projected into the same 
Coordinate Reference System (CRS).  

 
3.1 - Acquiring and preparing the DEM 
 
The first objective is to obtain a high-resolution DEM covering the project watershed. It is important for Methods 
2 and 3 that the DEM was acquired when streams were dry or nearly so, since the lidar bands used in most studies 
do not penetrate water. Naturally, larger rivers do not qualify. Method 1 is not  sensitive to this limitation. 
 
One of the most useful sources for elevation data in the United States is the USGS National Map website 
https://apps.nationalmap.gov/downloader/#/. To download a DEM, select your area of interest, then select 
'Elevation Products (3DEP)' and finally '1 meter DEM'. Click 'Search Products' to find what's available. If the 10 
km square tiles don't contain your entire watershed, you will need to download several tiles and merge them 
before proceeding. One meter data coverage remains spotty, although data acquisition is an ongoing process; the 
'1/9 arc-second DEM' data (~3 meters) may be acceptable if the stream is significantly wider than this pixel size. 
 
A file containing a polygon that circumscribes the watershed can be interactively defined and downloaded from 
the "USGS Stream Stats" website, https://streamstats.usgs.gov/ss/. Alternatively, a boundary for pre-defined 
hydrologic unit (HU) polygons can be downloaded from the USGS National Map website. It may be necessary to 
modify the downloaded watershed polygon to suit your project using QGIS graphical editing tools. You can learn 
how to edit QGIS vector data at: 
https://docs.qgis.org/3.16/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html?highlight
=edit. Note that QGIS treats point, line, and polygon layers as different types of vector data, all containing 
editable points. 
 
The following processing steps are recommended for all projects. Clipping the merged DEM to the watershed 
boundary (steps 3 through 5) is required only in Method 3, but working with a large, unclipped DEM increases 
processing time. 
 
1) Load GeoTIFF or other raster tile(s) containing the DEM(s) of interest into QGIS.       
 [Menu > Layer > Add Layer > Add Raster Layer...] 
  

•  You can also simply drag and drop the DEM files onto the project window. 
•  When choosing output files in all dialog boxes that follow, use the 3 dots to the right of the layer-name 

 box to open the Select File dialog to specify the full file path. 



2) If you have multiple DEM tiles, merge them into a single layer. 
 [Menu > Raster > Miscellaneous > Merge...] 

   
  

Figure 2: Four pre-merge, 10km by 10km DEMs and a separate 
vector layer for the watershed boundary (red line). 

Figure 3: Post-merge DEM with Layer Styling and separate 
watershed boundary. 



3) Load a watershed boundary file into QGIS. 
[Menu > Layer > Add Layer > Add Vector Layer...]  
 
• In QGIS, layers are drawn in the Map window starting from the bottom of the Layers panel toward the 

top, so arrange vector layers above raster layers by dragging them into place. 

 
4) Edit the watershed polygon boundary points if you deem it necessary. 

[Toolbar > Toggle Editing]  then  [Toolbar > Vertex Tool (Current Layer)] 
 
• Edit polygon vertices, then save changes and exit editing. 
 
[Toolbar > Save Layer Edits]   then  [Toolbar > Toggle Editing] 

 
5) Clip the DEM to the boundary of the watershed. 

 [Menu > Raster > Extraction > Clip Raster by Mask Layer...] 

           Top half                    Bottom half 



6) If culverts, bridges or other structures appear to obstruct water flow, digitize short line segments across the 
obstructions. You can download a "S_GEN_STRUCT.shp" file from FEMA as a useful starting point. 
[Menu > Layer > Create Layer > New GeoPackage Layer...] 

 
7) Manually digitize/edit channel segments into new/downloaded layer. 

[Toolbar > Toggle Editing]  then  [Toolbar > Add Line Feature] 
 
• Digitize line segments, then save changes and exit editing. 
 
[Toolbar > Save Layer Edits]  then  [Toolbar > Toggle Editing] 
 

8) Carve the new channel segments into the DEM raster. 
[Toolbox > GRASS > Raster > r.carve]   
 

    Top half              Bottom half 

important 



9) Fill closed depressions in the DEM to improve the accuracy of thalweg delineation and flow accumulation. 
[Toolbox > SAGA > Terrain Analysis - Hydrology > Fill sinks (wang & liu)] 

 
10)  Convert the final DEM's format to GeoTIFF format and compress it to reduce space. 
  [Right-click DEM layer in Layers panel > Export > Save as...] 

               

                 

Figure 4: Final post-clip-carve-fill DEM of the Deer Creek watershed. 



3.2 - Extracting the thalweg and flow accumulation from the DEM 
 
Inundation maps for all 3 methods can be generated using thalweg coordinates derived from the DEM. It is 
important that the thalweg accurately follows the stream bottom in nearly monotonic descent for Methods 2 and 3. 
Method 1 is less sensitive to deviations from the stream bottom, so FEMA's S_PROFIL_BASLN thalwegs can be 
used. However, they often deviate considerably from the thalweg defined by lidar and may need to be extensively 
edited if you choose to use them. 
 
QGIS can determine the direction of flow at every pixel in a digital map. This enables it to accumulate the number 
of upstream pixels that contribute to flow through each pixel (WaterAccum). This in turn enables it to determine 
the pixel-by-pixel location of larger flow patterns, i.e., streams (StreamSegs). These streams are well-defined and 
are generally downstream-monotonic. The other product of this process, a digital map of flow accumulation, is an 
essential input only to Method 3. 
 
1) Generate 2 new raster layers containing stream segments and accumulated flow respectively.  

[Toolbox > GRASS > Raster > r.watershed] 
 
• Set 'Minimum size of exterior watershed basin' to a large enough number of pixels to eliminate most 

inconsequential streams.  
 
    

 

    Top half             Bottom half 



2) Thin the streams.               3)  Convert the raster layer to a line-vector layer. 
[Toolbox > GRASS > Raster > r.thin]     [Toolbox > GRASS > Raster > r.to.vect] 

      

Figure 5: Thinned, vectorized streams in Deer Creek prior to deleting all stream segments except the branch of interest and showing several edit 
tools and the 'Select Features by Polygon' tool useful for selecting multiple features at once. 



 
4)  Edit the stream line-vector layer to remove all streams except the branch being studied. Zoom in at 
 confluences to remove all dangles (residual single or multiple points branching off the main branch). 

[Toolbar > Toggle Editing]  then  [Toolbar > Select Features by Polygon] 
 
• Encircle unwanted stream segments with the mouse and press the keyboard delete key. Then save the 

changes and exit. 
 

 [Toolbar > Save Layer Edits]  then [Toolbar > Toggle Editing] 
 

• If Save is unsuccessful, exit edit mode without saving, execute step 5, then repeat this step. When Save is 
successful, skip step 5. 

 

Figure 6: Zoomed image of thinned, vectorized streams showing pixel-to-pixel progression of thalwegs 
along path of near-constant descent. 

Figure 7: Stream vectors after half the segments have been deleted and the other 
half have been selected for deletion. 



5) Resolve any remaining topological problems. 
[Menu > Vector > Topology Checker] 
 
• In the 'Topology Checker Panel' shown in Fig. 8, click the 'wrench' icon. Then add rules to the 'Topology 

Rule Settings' dialog box shown in Fig. 9. Finally, click 'OK'. 
• Click the larger, 'check' icon in the 'Topology Checker Panel' to display errors. You can click on any row 

of errors to find and center that error in the project window. 
• Use edit features to correct errors and save the edited result. 'pseudo node' errors require deleting and 

redigitizing points. 'multipart feature' errors can be fixed with: 
 [Toolbox > Vector geometry > Multipart to singleparts]. 

 

6) Merge line segments comprising the stream branch of interest to create a single connected line-vector. 
 (For resulting image, see Fig. 1.) 

[Toolbar > Toggle Editing]  then  [Toolbar > Select Features by Polygon] 
 
• Encircle all remaining stream segments that comprise the branch of interest. 
 
[Toolbar > Advanced Digitizing Toolbar > Merge Selected Features] 

 [Toolbar > Save Layer Edits]  then  [Toolbar >Toggle Editing] 
 
  

Figure 8: Topology Checker Panel reporting topological 
errors after invoking dialog box in figure at right and 
clicking large 'check' icon. 

Figure 9: Dialog box invoked by wrench icon on 
Topology Checker Panel to specify topological errors 
to check. 



4 - METHOD 1 PROCESSING 
 
In addition to the preprocessed DEM (Sec. 3.1) and the XYZtb file of thalweg coordinates, Method 1 requires an 
additional table of XYZm coordinates of flood level elevations that were measured in the field, in comma-
separated-value file format (CSV).  In the latter, Zm is the measured flood water elevation for each site relative to 
sea level, and X and Y are the coordinates at each measurement site. These measured flood levels will be 
interpolated to each point along the thalweg; interpolation can be accomplished in Excel using the Visual Basic 
program included as part of this Supplement, or by a method or program of your own choosing. The result is a 
new CSV file providing XYZws values for several thousand closely-spaced points along the thalweg, where XY 
are the thalweg’s spatial coordinates and Zws is the interpolated flood level. These Zws values are then projected 
across the DEM using IDW nearest-neighbor processing. 
 
To use our method, the XYZtb positions along the thalweg, determined from the Stream_line vector file from Sec. 
3.2, must be exported from QGIS into a CSV file and imported into Excel. This file is augmented by adding four 
new columns, representing the XYZmD points corresponding to the measured flood levels plus distance along the 
thalweg (D), and then the file is processed to assign, by interpolation, a flood level to each point along the 
thalweg. After interpolation, the file is exported from Excel into a CVS file, and then imported back into QGIS.  
Details are as follows. 
 
1) Execute all Preprocessing steps. 
 
2) Convert the cleaned, line-vector thalweg layer from Preprocessing (Stream_line) into point-vector format, 

adding DXYZtb coordinates at one-meter intervals along the thalweg (D is cumulative distance; Ztb is stream 
bottom elevation). 
[Toolbox > SAGA > Terrain Analysis - Profiles > Profiles from lines] 

  
3) FYI: To view and edit any vector layer in ASCII format, load the 'Attribute Table'. 

[Right-click the layer name in the Layers panel > Open Attribute Table] 
 

Figure 10: Example of a portion of the attribute table for the thalweg point layer. 

In older versions of QGIS, the "Profiles from 
Lines" tool has an additional checkbox before 
the "Profiles" entry named "Each Line as new 
Profile". This must NOT be checked. 



4) Import your CSV file containing flood level elevations measured in the field. 
 [Menu > Layer > Add Layer > Add Delimited Text Layer...]           

      
5)   Export the imported CSV layer to a GPKG format layer in QGIS.  
 [Right-click CSV file > Export > Save Features As...] 

Figure 11: Input CSV file containing measured 
flood elevation points for 2008 St. Louis flood. 



6) Add a column to the measured flood level layer containing cumulative distance values (DIST) from the 
thalweg layer. These values are taken from points on the thalweg where they are most nearly coincident with 
measured elevation layer points. 

 [Vector general > Join attributes by nearest] 

 
7) Export the thalweg elevation layer and the modified flood level layer into separate CSV files. Save all but the 

DIST_SURF column from the thalweg file and only 4 columns from the flood level file. 
 [Right-click the layer name in the Layers panel for each layer > Export > Save Features As...] 



8) Import the thalweg elevation CSV file into Excel, occupying columns A to F (adapt column letters to your 
data as needed). Microsoft Excel for Mac version 16.51 was used for these examples. 

 
• Save the file as an "Excel Macro-Enabled Workbook (.xlsm)" (important!). 

 
9) Import your measured flood elevation quadruplets into the same Excel file occupying columns H to K,  

leaving column G between them empty.  
 

• Label column G 'FloodElev' in row 1. 
• Label the XY coordinate columns H and I  'X2' and 'Y2'. 
• Label column J  'FloodElev2'. 
• Label column K 'FloodDist'. 

 
10) If you do not have a 'Developer' tab at the top of the Excel window, add it (instructions are for Mac OSX). 
 [Menu > Excel > Preferences] 
 

• Open the 'Ribbon & Toolbar' dialog box and check the 'Developer' box under 'Main Tabs'. 
• Open the 'Calculation' dialog box and check the 'Automatic' button. 

 
11) Import a Visual Basic function into Excel that will populate FloodElev cells with measured flood elevations 

interpolated to each point in the thalweg table. 
[Developer tab > Visual Basic icon] 
[Visual Basic window > Menu > File> Import File...] 
 
• Click 'Options' button and enable 'VB Files'.  
• Select file 'LinearInterpCode_2.bas' and click 'Open' to load it into the into the editor window. 
• Under [VBAProject > Modules] double-click 'Module1' to view the code. 
• The Visual Basic window can now be closed if you wish. 

 

Figure 12: Excel Macro-Enabled Workbook file setup prior to execution of interpolation function, LinearInterp (step 12). 



12) For every selected row in the thalweg table, populate the FloodElev column with computed flood elevations 
by linearly interpolating between enclosing flood elevation values from the measured flood elevation table. 
• Construct an Excel formula to call the LinearInterp function. 

o Highlight the G column cell corresponding to the first row in the Excel table that will receive a 
FloodElev value (G2 in Fig. 12).  Then on the 'Formulas' tab, click the 'Insert Function' button. 

o In the 'Formula Builder' window, select 'Show All Functions' and scroll down to the ' LinearInterp' 
function; select it and click 'Insert Function'. 

o In the formula box, replace the '=LinearInterp()' entry with '=LinearInterp($Em$i:$Em$j, 
$Dm$i:$Dm$j, Ct)', where E and D represent the columns containing 'FloodElev2' and 'FloodDist' 
values; C represents the thalweg distance (DIST); and i and j are row numbers. The 't' subscript refers 
to thalweg points, and the 'm' subscript refers to measured flood elevations.  

 For example:  '=LinearInterp($J$2:$J$16, $K$2:$K$16, C2)' 
• Execute the LinearInterp function. 

o Press the "Done" button, and a flood elevation value should appear in cell G2. If the value is -99999, 
it is only because the thalweg point is not within the range of the measured points, so continue. 

o Click cell G2 and a tiny square will appear in the lower right corner. Grab the square and drag down 
to the last cell in the list of values to fill. When released, Excel will fill the selected G column cells.  

o Wait for the column to finish redrawing (!), then save the Excel file. This function does not 
extrapolate. Any points in your thalweg distance range that fall outside the range of your measured 
elevations will be given values of -99999. 

 
13) Convert FloodElev cell values from formulas to numbers and clean up. 

• Select all of column G. 
• On the 'Home' menu click the 'Copy' icon; then click the 'Paste' icon. A clipboard icon should appear. 
• Click the clipboard icon and select 'Values Only'. This will convert formulae to values. 
• Delete columns H hrough K corresponding to the original measured flood elevation data. 
• Save the .xlsm file as a CSV file named 'Stream_points_elev_interp.csv'. 
 

14) Import the interpolated CSV file into QGIS, then export it as a GeoPackage layer. 
 [Menu > Layer > Add Layer > Delimited Text Layer...]  

 
[Right-click the name of CSV layer > Export > Save Features As...]  (save in GPKG format) 



15) Decimate the layer by reducing the point density of the thalweg from 1-meter to ~20-meter intervals to 
improve processing time in the following 'Grid' step. 

 [Toolbox > GRASS > Vector > v.edit] 
 
•  In the "WHERE conditions of SQL statement..." box, 20 represents the nth point to keep. 

     Top half             Bottom half 
 
16) Delete all points with null (-99999) values. 
 [Right-click the thinned point layer > Open Attribute Table] 
 

• Click the edit icon, then select rows with -99999. 
• Click the garbage can icon to delete rows. 
• Click the save icon, then click the edit icon to exit edit mode. 

 
17) Project flood level elevations from the thalweg across the surrounding terrain using an inverse distance 

weighting (IDW) and nearest neighbor search (NN) gridding algorithm. This produces a raster water surface 
elevation layer. IDW with NN searching allows you to experiment with alternative parameter values. 

 [Toolbox > GDAL > Raster analysis > Grid (IDW with NN searching)] 
 
• "Radius of search circle" = For each DEM pixel, thalweg elevation points up to this distance away will be 

searched for their nearest neighbor(s). 
• "Additional command-line parameters" = -txe xmin xmax -tye ymin ymax -outsize xsize ysize     where:  
  xmin and xmax are the DEM layer's x-bounds in meters;                        
  ymin and ymax are the DEM layer's y-bounds in meters;                        
  xsize and ysize are the DEM layer's Δx and Δy in meters. 



 
18) Convert the water elevation layer to a water depth layer by subtracting terrain elevations. 
 [Menu > Raster > Raster Calculator...] 

 



19) Change parameters in the Layer Styling panel for the newly clipped surface so it displays correctly. 
• Highlight the inundation map name in the Layers panel. 
• [Style > Singleband pseudocolor] 
• [Style > Min and Max > 'set your valid min and max DEM elevations']  (important - min should be 0) 
• [Style > Color ramp > Blues] 
• [Style > Color ramp > Invert color ramp]  
• [Style > Clip out of range values > Check]  (important) 

 
You can iteratively create Method 1 inundation maps by repeating steps 4-17) to 4 -19) with different parameters. 
Fig. 13 shows the result of applying this procedure to Deer Creek project data. 
 

   

Figure 13: Deer Creek inundation map overlain on a satellite photo showing flood depths generated using the Method 1 processing 
procedure using measurements from the 2008 flood.The blue region is the water depth in the computed flood zone; darker colors represent 
deeper water. The black line represents the limit of the 100-year flood as computed by FEMA for comparison. Flood depths more than 
1000m from the thalweg are not shown, because 1000m was used as the search limit when gridding thalweg water depths. Flood 
measurements are available only in the lower half of the river. 

 
  



5 - METHOD 3 PROCESSING  
 
Method 3 uses the line-vector thalweg layer (Stream_line) and the water accumulation layer (WaterAccum) 
generated from a DEM map, as described in Sec. 3.2, to generate a DXYZtbW point-vector layer.  The D 
coordinate represents distance along the thalweg, and Ztb represents stream-bottom elevation. W represents the 
accumulated flow that passes through each point on the thalweg from every contributing, upstream pixel. The 
channel bottom vector is projected across the DEM using the IDW nearest-neighbor algorithm to produce the 
bottom elevation raster layer BotElev. The WaterAccum vector is projected across the DEM using the NNGA 
nearest-neighbor algorithm to produce another raster layer, FloodAccum. Layers BotElev and FloodAccum are 
next used, together with fitting constant b and power c from the paper's Eq. 3, to compute flood elevation map 
WaterElevation. The DEM elevation layer is next subtracted from the WaterElevation layer to produce the 
WaterDepth layer. This map is finally clipped to the terrain. The following processing steps are required. 
 
1) Execute all Preprocessing steps. 
 
2) Convert the line-vector thalweg layer from Preprocessing into point-vector format, adding DXYZtbW 

coordinates at 1-meter intervals along the thalweg. 
[Processing Toolbox -> SAGA -> Terrain Analysis - Profiles -> Profiles from lines] 

  

 

Figure 14: Attribute Table for thalweg after addition of water accumulation. 
Values are expressed as number of pixels or, equivalently for these data, m2. 



 
3) Decimate the thalweg point layer containing water accumulation values by reducing the point density from 
 1-meter to ~20-meter intervals to improve processing time in the following "Grid" steps. 
 [Toolbox > GRASS > Vector > v.edit] 
 

•  In the "WHERE conditions of SQL statement..." box, 20 represents the nth point to keep. 

   Top half              Bottom half 
 
4) Project the thinned, thalweg bottom elevations across the surrounding terrain using inverse distance weighting 
 (IDW) and nearest neighbor search (NN) to produce a raster bottom elevation layer (see left image below). 

[Toolbox > GDAL > Raster analysis > Grid (IDW with NN searching)] 
 
• "Radius of search circle" = For each DEM pixel, thalweg elevations up to this distance away will be   

sought to find the nearest one(s); you can experiment with different values. 
• "Max number of data points to use" = You can experiment with different values; 1 is suggested. 
• "Min number of data points to use" = You can experiment with different values; 1 is suggested. 
• "Z value from field" = Important! Choose the field with interpolated bottom elevations. 
• "Additional command-line parameters" = -txe xmin xmax -tye ymin ymax -outsize xsize ysize 
  where:  
  xmin and xmax are the DEM layer's x-bounds in meters;            
  ymin and ymax are the DEM layer's y-bounds in meters;            
  xsize and ysize are the DEM layer's Δx and Δy in meters. 



 
5) Project thalweg water accumulation values across the surrounding terrain using IDW and NN to produce a 

raster layer with projected accumulation. (see right image above). 
 [Toolbox > GDAL > Raster analysis > Grid (IDW with NN searching)] 
 

• Use the same values as in 4) above. 
• "Z value from field" = Important! Choose the field with water accumulation. 

 
 
 



 
6) Use constants b and c described in the "New Method 3" section of the paper to compute WaterElevation, the 

elevation of flood water above mean sea level. Important! In the equation below, Project_bottom_elev is in 
meters, but Project_water_accum must be converted to km2, hence the division by 1000000. 
[Menu > Raster > Raster calculator] 
 
• Example of equation in raster calculator: 
 "Project_bottom_elev@1" + 1.86 * ("Project_water_accum@1" / 1000000.) ^ 0.30 

Figure 15: Stream bottom elevations projected to a radius of 1000m from 
thalweg. Maximum elevation (dark blue) is 170.1 m, and minimum elevation 
(light blue) is 126.6 m. 

Figure 16: Water accumulation per pixel projected to a radius of 1000m from 
thalweg. Maximum accumulation (dark blue) is 93,206,000 m2, and minimum 
accumulation (light blue) is 2,341,000 m2. 



    

7) Generate a water depth layer by differencing the WaterElevation layer and the DEM elevation layer.  
[Menu > Raster > Raster Calculator...] 
 
• Example of equation in raster calculator:  "WaterElevation@1"	  -‐	  "DEM_final@1 



8) Clip the water depth layer to the terrain, color and display over a satellite image. 
 [Style > select 'Singleband pseudocolor'] 
 [Style > select a 'Color ramp'] 
 [Style > set 'Min' layer value to 0.0] 
 [Style > check the 'Clip out of range values' box] 
 
You can iteratively create Method 3 inundation maps by repeating steps 4) to 8) using different parameters. Fig 17 
shows the result of applying Method 3 to Deer Creek project data. 
 
Only the main branch of the Deer Creek watershed was treated here, but tributaries can be added separately. 

 
  

Figure 17: Deer Creek inundation map showing flood depths generated using the Method 3 processing procedure. The yellow line is the boundary of 
the Deer Creek watershed. The blue region is the computed flood zone; darker colors represent deeper water. The black outline represents the limit 
of the 100-year flood as computed by FEMA for comparison. Fitting constant b and power c used in the application of Eq. 3 from the paper are 1.86 
and 0.3 respectively. Flood depths more than 1000m from the thalweg are not shown, because 1000m was the search limit used to grid thalweg 
water depths. 



6 - FIXING QGIS ERRORS 
 
 On some computers, newer versions of QGIS may fail when executing certain tools. 
  
 If the error message resembles "UnicodeEncodeError: 'ascii' codec can't encode character '\xb0' in position 
888.", then you can take the following steps to correct the problem: 

• Find your QGIS application and open the code; for example, on a Mac right click the app and select Show 
Package Contents. 

• Drill down to find the file named "Grass7Utils.py" in directory: 
Contents/Resources/python/plugins/processing/algs/grass7. 

• Find this code near line 95: 
o   with open(wkt_file, 'wt') as f: 
o   f.write(wkt) 

• Duplicate the lines and edit them to read: 
o   with open(wkt_file, 'wb') as f: 
o   f.write(wkt.encode("ascii", "ignore")) 

• Comment out the 2 original lines with a '#' character in the first column (in case you need to revert to the 
original later) and save the file. Make sure you use an editor that saves the file as pure text; .doc or .rtf  
files etc. will not do. 

• Save your project, exit QGIS and reload it. 
 

If the error message resembles "ERROR 1: PROJ: proj_create_from_database: Cannot find proj.db", then             
do this: 

• On the QGIS menu, select Plugins > Python Console. 
• At the very bottom of the new window, enter these two lines, clicking enter after each: 

o   import os 
o   os.environ["PROJ_LIB"]="/Applications/QGIS.app/Contents/Resources/proj"  (use the path for 'proj' 

appropriate to your installation here) 
• Save your project, exit QGIS and reload it. 

 


